Blog

AirDrop ? Only with some Macs!

AirDrop not working for you on your Mac? Perhaps it's not compatible. Apple has issued a knowledge base article showing the Macs AirDrop does work with. Essentially, if you have a Mac from the last three years you are probably OK, but check the list below to be sure. If it's not supported in the 'Go' menu, it's not supported on your Mac.

 

Macs that support AirDrop in OS X Lion

The following list shows the earliest of each Mac model type that is supported. If your Mac is the same, or newer than the model listed, then it supports AirDrop.

  • MacBookPro (Late 2008 or newer)
  • MacBook Air (Late 2010 or newer)
  • MacBook (Late 2008 or newer)
  • iMac (Early 2009 or newer)
  • Mac Mini (Mid 2010 or newer)
  • Mac Pro (Early 2009 with AirPort Extreme card, or Mid 2010)

View the full article HERE